Incident

Incident Report for WiscNet

Update

We are seeing the member port in alarm at this time. Please verify equipment plugged in and power verified
Posted May 30, 2026 - 07:49 CDT

Investigating

We are currently investigating this issue.
Posted May 30, 2026 - 07:45 CDT
This incident affects: TEACH - Milwaukee (Paris J1 School District).