Date & Time of Incident: 12/17/25 starting at 4 AM Duration: 11 hours Technician(s): NA Review Date: NA
Root Cause: Failed Cards
Brief Summary: 2 cards needed to be replaced on GLS's local provider's network
Posted Dec 17, 2025 - 15:32 CST
Update
GLS continues to work with their provider to resolve this issue. There is no ETR yet at this time.
Posted Dec 17, 2025 - 14:23 CST
Update
GLS continues to work with their provider to resolve this issue. There is no ETR yet at this time.
Posted Dec 17, 2025 - 11:41 CST
Update
We are continuing to investigate this issue.
Posted Dec 17, 2025 - 09:45 CST
Update
Hello,
GLS is aware of an issue with their LMP that is causing service disruptions. They have been working to get this resolved. There is no ETR yet at this time.
Posted Dec 17, 2025 - 09:00 CST
Investigating
We are currently investigating this issue.
Posted Dec 17, 2025 - 08:02 CST
This incident affected: Northeast Wisconsin Technical College.