Monroe School District - Down - 2213829

Incident Report for WiscNet

Monitoring

We have been informed that this was impacted b a commercial power event and has since restored as of approximately 10:54 AM CD this morning. We will continue to monitor this for now.
Posted Mar 14, 2026 - 11:13 CDT

Investigating

We have observed an issue affecting this location beginning at approximately 09:59 AM CDT this morning. We are investigating this at this time.
Posted Mar 14, 2026 - 10:19 CDT
This incident affects: Monroe School District.