Living Hope Lutheran School | 2197372

Incident Report for WiscNet

Resolved

This site is down due to a disconnect of service.
Posted Jan 28, 2026 - 16:23 CST

Update

Hello,

GLS will be dispatching a technician on site this afternoon.
Posted Jan 28, 2026 - 13:41 CST

Update

Hello,

We have opened a ticket with TEACH for investigation at this time.

Thank You,
Posted Jan 28, 2026 - 10:38 CST

Investigating

Hello,

We are observing the Living Hope Lutheran School site down as of 9:47 AM CST.

This is a teach site and we will reach out to the for investigation.

Thank You,
Posted Jan 28, 2026 - 10:06 CST
This incident affected: TEACH - Milwaukee (Living Hope Lutheran School).