Waterford Union High School | 2224846

Incident Report for WiscNet

Postmortem

Date & Time of Incident: 4/14/26 from 3:44 AM to 10:33 AM

Duration: 6 hours 41 minutes

Technician(s): Barry

Review Date: 4/14

Brief Summary: On 4/14/26 from 3:44 AM to 10:33 AM, Waterford Union High School was down due to a local power outage.

Root Cause: Local Power outage.

Posted Apr 14, 2026 - 11:36 CDT

Resolved

Hello,

We are seeing the site has restored as of 10:33 AM this morning.
Posted Apr 14, 2026 - 11:34 CDT

Update

We have opened ticket 12069090 with GLS. While GLS worked with their carrier to investigate please verify power and equipment onsite. If you have any questions please reach out to Wiscnet or GLS.
Posted Apr 14, 2026 - 04:58 CDT

Investigating

We are currently investigating this issue.
Posted Apr 14, 2026 - 04:28 CDT
This incident affected: TEACH - Milwaukee (Waterford UHS School District).