WiscNet Outage Muliple Members

Incident Report for WiscNet

Update

GLS/Teach is ongoing in their restoration efforts currently but have not been given a hands-off confirmation so we shall continue to monitor this for now.
Posted Feb 21, 2026 - 14:49 CST

Identified

This issue has been identified and is currently being worked on. We have seen services as up without issue since approximately 10:30 AM CST this morning but have not been given the hands-off confirmation that the resolution has been completed yet. We will continue to monitor this.
Posted Feb 21, 2026 - 13:06 CST

Update

This issue is currently being investigated by GLS/Teach via their ticket of 11978027. We will continue to provide updates as we learn more.
Posted Feb 21, 2026 - 11:00 CST

Update

We are continuing to investigate this issue.
Posted Feb 21, 2026 - 10:04 CST

Investigating

We are currently investigating a impact to your services which began at approximately 09:145 AM CST. In the meantime please verify power and equipment on site.
Posted Feb 21, 2026 - 10:04 CST
This incident affects: TEACH - Milwaukee (Bristol School District #1, Northern Ozaukee School District) and TEACH - Madison (CESA 9, Waterloo School District).