#2250378 - Seneca School District - DOWN

Incident Report for WiscNet

Postmortem

Commercial power outage

Posted Jun 17, 2026 - 20:16 CDT

Resolved

Hello,


We're seeing this service resolved, we attributed this outage due to a local power outage.

Thank you,
Posted Jun 17, 2026 - 20:16 CDT

Investigating

Hello,



We've detected an outage on your service starting around 5:41PM. If this outage is unexpected and you've verified power onsite, please reach out to 866-558-1920 and create a trouble ticket. If you have any questions or concerns, please reach out to 608-442-6761.



Thank you,
Posted Jun 17, 2026 - 17:54 CDT
This incident affected: TEACH - Madison (Seneca School District).