Outage | Kiel Scool District | 2240571

Incident Report for WiscNet

Postmortem

Date & Time of Incident: 12:45AM CDT 5/26/26

Duration: 96 Minutes

Technician(s): Tim B & Octavia G

Review Date: 5/26/26

Brief Summary: Device lost connection briefly, no indication of any power alarms.

Posted May 26, 2026 - 09:20 CDT

Resolved

We now observe services restored as of 1:55AM CDT.
Posted May 26, 2026 - 09:17 CDT

Investigating

We are currently investigating. GLS has requested the customer open a ticket with them directly and confirm power to the equipment and all devices are connected properly.
Posted May 26, 2026 - 00:39 CDT
This incident affected: TEACH - Milwaukee (Kiel Area School District).