Update
Hello,
We got word from our transport partner that as of right now, there are no techs available to dispatch to the site to replace the faulty transport card. We have been told that they will talk with their dispatch center again in the morning to get someone out to address this issue. No ETR is available at this time.
Posted Dec 28, 2025 - 02:06 CST
Update
Hello,
The transport provider has identified a faulty network card in their core office, they are working on getting a technician dispatched with no ETA.
Posted Dec 27, 2025 - 22:46 CST
Update
Hello,
The issue has been identified as an issue with a device on the core path of the network. Restoration efforts are ongoing with no ETR.
Posted Dec 27, 2025 - 20:37 CST
Update
Hello,
We are continuing to push the transport provider for an ETR with nothing set in stone at this time. We continue to push and escalate the issue.
Posted Dec 27, 2025 - 19:00 CST
Update
Hello,
We are continuing to push the transport partner to narrow down the cause of the outage. More to come.
Posted Dec 27, 2025 - 17:56 CST
Update
Hello,
We are continuing to push for a resolution from the transport provider.
No ETR has been provided.
Posted Dec 27, 2025 - 16:54 CST
Update
Hello, we are currently investigating issues with our partner, issue has been escalated. We will continue to provide updates as soon as we have further information.
Posted Dec 27, 2025 - 14:15 CST
Update
We are continuing to investigate this issue. We apologize for the inconvenience and we will update as soon as we have further information.
Posted Dec 27, 2025 - 13:03 CST
Investigating
We are currently investigating an issue affecting multiple sites starting at 11:50 AM. We will update as soon as we have further information.
Posted Dec 27, 2025 - 12:22 CST
This incident affects: TEACH - Milwaukee (Bonduel School District, Bowler School District, Brighton #1 School District, CESA 1, Chilton School District, Elcho School District, Elkhart Lake-Glenbeulah School District, Erin School District, Freedom Area School District, Geneva J4 School District, Gilmanton School District, Granton Area School District, Grantsburg School District, Hartford J1 School District, Horicon School District, Hortonville Area School District, Howards Grove School District, Kewaunee School District, Kiel Area School District, Kimberly Area School District, Kohler School District, Lac du Flambeau #1 School District, Lake Country School District, Lakeshore Technical College, Lena School District, Linn J6 School District, Living Hope Lutheran School, Good Shepherd Lutheran School, Medford Area Public School District, Menominee Indian School District, Milton School District, New London School District, Prairie Farm Public School District), TEACH - Madison (Birchwood School District, Black Hawk School District, Boscobel Area School District, Boyceville Community School District, Brillion School District, Cambria-Friesland School District, Cambridge School District, Cassville School District, CESA 4, CESA 5, CESA 8, CESA 9, Coleman School District, Crivitz School District, Cuba City School District, Darlington Community School District, Deerfield Community School District, Delavan-Darien School District, Dodgeville School District, East Troy School District, Edgar School District, Edgewood High School, Ellsworth Community School District, Elmwood School District, Florence County School District, Gillett School District, Glenwood City School District, Goodman-Armstrong Creek School District, Green Lake School District, Hayward Community School District, Highland School District, Hurley School District, Hustisford School District, Iola-Scandinavia School District, Iowa-Grant School District, Ithaca School District, Johnson Creek School District, Kewaskum School District, Lake Mills Area School District, Lodi School District, Marathon City School District, Marion School District, Markesan School District, Mercer School District, New Glarus School District, Niagara School District), and Nicolet Area Technical College.