Bellville School district | down | 2185095

Incident Report for WiscNet

Resolved

Resolving this as we have opened a major incident
Posted Dec 17, 2025 - 08:06 CST

Investigating

We are currently investigating this issue.
Posted Dec 17, 2025 - 07:02 CST
This incident affected: TEACH - Madison (Belleville School District).