Edgerton School District | 2195519

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 08:03 CST

Update

The outage cleared at 4:49 AM CST.
Posted Jan 23, 2026 - 08:03 CST

Investigating

We are currently investigating this issue.
Posted Jan 23, 2026 - 03:25 CST
This incident affected: Edgerton School District.