2238560 | Jackson County Down

Incident Report for WiscNet

Resolved

Hello,

At this time the maintenance has been completed.

Thank you,
Posted May 19, 2026 - 06:33 CDT

Investigating

Hello,

Starting at 1:24 am we lost connection to our onsite equipment.

Our provider has informed us that this is impacted by a maintenance that are preforming. The window ends at 6 am. We will follow up after the window to confirm your service is restored and the maintenance is complete.

Thank you,
Posted May 19, 2026 - 01:42 CDT
This incident affected: Jackson County.