Wabeno School District | 2258580

Incident Report for WiscNet

Resolved

We're seeing services restored as of 3:30 AM. Please reach out if you have any questions.
Posted Jul 10, 2026 - 07:36 CDT

Investigating

Hello,

We are seeing alarms indicating Wabeno School District is down at this time. At this time please verify power and equipment and reach out to TEACH/GLS to open an investigation on this issue. Please reach out with any questions.
Posted Jul 10, 2026 - 02:05 CDT
This incident affected: TEACH - Madison (Wabeno Area School District).