[2280233] La Crosse Public Library - Down

Incident Report for WiscNet

Postmortem

Date & Time of Incident:8/21/26 9:57am

Duration: 88 minutes

Technician(s): Payton

Review Date: 8/21/26

Brief Summary: WiscNet NOC observed a loss of connection for La Crosse Public Library.

Posted Aug 21, 2026 - 12:27 CDT

Resolved

Hello,

The WiscNet NOC has observed all alarms clear.
Posted Aug 21, 2026 - 12:24 CDT

Identified

Hello,

At 9:57am, the WiscNet NOC lost access to our device at Lacrosse Public Library. Please verify power and equipment onsite.
Posted Aug 21, 2026 - 10:25 CDT
This incident affected: La Crosse Public Library.