2223072 | Owen-Withee school district down

Incident Report for WiscNet

Resolved

Hello,

At this time the maintenance has been completed.

Thank you,
Posted Apr 09, 2026 - 07:33 CDT

Identified

Hello,

Starting at 2:14 am we observed our hand off device go down.

Investigations revealed that our provider is preforming a maintenance that is impacting this. The window is set to end at 7 am CST.

Please reach out with any questions.

Thank you,
Posted Apr 09, 2026 - 02:57 CDT
This incident affected: Owen-Withee School District.