Outage - Deerfield high school | 2232810

Incident Report for WiscNet

Update

We are continuing to investigate this issue.
Posted May 02, 2026 - 05:17 CDT

Investigating

We are currently investigating this issue.
Posted May 02, 2026 - 03:21 CDT
This incident affects: TEACH - Madison (Deerfield Community School District).