Pittsville SD Down - 2286725

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 21:27 CDT

Update

Hello,

We are seeing the site back up. Please check your equipment and reach out if you have any questions.

Thanks,
Posted Sep 03, 2026 - 21:27 CDT

Investigating

Hello,

At 8:27 pm we observed an outage at Pittsville School District. We have observed power outages in the area. They have an ETR for power at 10 pm cst. Please reach out if you have any questions.

Thanks,
Posted Sep 03, 2026 - 21:04 CDT
This incident affected: TEACH - Milwaukee (Pittsville School District).