Saint Croix Falls School District site down | INC0566035

Incident Report for WiscNet

Resolved

Greetings,

Please be advised that we are now seeing all services restored. Please let us know if you have further questions or issues.
Posted Mar 19, 2025 - 16:00 CDT

Monitoring

Greetings,

Please be advised that we are now seeing all services restored. Please let us know if you have further questions or issues.
Posted Mar 18, 2025 - 15:51 CDT

Investigating

The WiscNet NOC is currently seeing multiple devices as unreachable on site. Please verify power and equipment on site as soon as possible.

Please contact the WiscNet NOC if you have any further questions.

608-442-6761 option 1
noc@wiscnet.net
Posted Mar 18, 2025 - 15:09 CDT
This incident affected: Saint Croix Falls School District.