2238637 | Owen-Withee School District | Down

Incident Report for WiscNet

Postmortem

The provider had a network outage that cleared at 5/19/2026 9:26:03 AM. Logs indicate no port bounces

Posted May 19, 2026 - 09:40 CDT

Resolved

The provider stated the network event has been resolved, and traffic has returned to normal amounts.
Posted May 19, 2026 - 09:39 CDT

Identified

Hello,

The last mile provider has an on-going network event in the area of Owen Withee Wisconsin and is currently investigating.
Posted May 19, 2026 - 08:41 CDT

Investigating

Hello,

We see the connection for the Owen Withee School down, and we are investigating further. Please reach out and let us know if power is verified onsite.
Posted May 19, 2026 - 08:13 CDT
This incident affected: Owen-Withee School District.