2245776 | Multiple Sites Down

Incident Report for WiscNet

Postmortem

Maintenance event has been completed and services restored.

Posted Jun 09, 2026 - 07:44 CDT

Resolved

Maintenance event is complete and services are restored.
Posted Jun 09, 2026 - 07:44 CDT

Update

We are continuing to monitor for any further issues.
Posted Jun 09, 2026 - 01:17 CDT

Monitoring

Hello,

We are reaching out to inform you of a maintenance event that is currently impacting your services. Please be advised that this maintenance event is scheduled to run until 6AM CDT.

Thank you,
Posted Jun 09, 2026 - 01:16 CDT
This incident affected: Middleton-Cross Plains Area School District and State of Wisconsin Investment Board.