Date & Time of Incident: 4/27 1:48 PM - 4/28 6:28 AM CT
Duration: 4/27 1:48 PM - 4/28 6:28 AM CT
Technician(s): Jake
Review Date: 4/28
Brief Summary: Multiple sites were observed experiencing brief connectivity issues. After investigations with the provider we observed sites stabilize with all sites remaining clear since the morning of 4/28.
Posted Apr 28, 2026 - 14:58 CDT
Resolved
This incident has been resolved.
Posted Apr 28, 2026 - 14:55 CDT
Monitoring
WiscNet has observed all sites remain stable with no further issues observed. Please reach out if you experience any further issues.
Posted Apr 28, 2026 - 14:55 CDT
Update
The WiscNet NOC has observed all sites remain stable apart from Genoa City J2 School District, which has been showing bouncing issues. If you continue to experience issues, please contact GLS Tech Support for 24x7/outages/incidents at 866-558-1920.
If you have any additional questions, please contact WiscNet NOC.
Posted Apr 28, 2026 - 08:17 CDT
Update
We are only seeing issues currently with Genoa City J2 School District. We have escalated this case with GLS. More information to come.
Posted Apr 27, 2026 - 23:24 CDT
Update
We are continuing to investigate this issue.
Posted Apr 27, 2026 - 15:07 CDT
Update
We've observed the majority of the bouncing cease, with some issues still lingering. Investigations with TEACH remain on-going. They have made us aware of a higher level outage affecting some of the sites and will provide more information as they continue to investigate.
Posted Apr 27, 2026 - 14:53 CDT
Update
We are currently observing multiple outages across the area. We're working with our local provider to investigate the issue further. We will continue to provide updates as we know more.
Posted Apr 27, 2026 - 14:23 CDT
Investigating
We are seeing various TEACH/GLS sites bouncing in and out of alarm showing connectivity issues. We have contacted GLS for investigation and will update as we learn more information.
Posted Apr 27, 2026 - 14:21 CDT
This incident affected: TEACH - Milwaukee (Genoa City J2 School District, Linn J6 School District, Waterford Graded J1 School District) and TEACH - Madison (Mercer School District).