[2281671] Mishicot School District - 400561 - Down

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 11:16 CDT

Identified

We have been advised by GLS/TEACH of a loss of connection to your device on site at Mishicot School District - 400561. Please verify power and equipment on site. GLS/TEACH is currently investigating this issue. Your current GLS/TEACH ticket number is **12371932** **.** If you need further assistance, please reach out to GLS/TEACH tech support,

If you have any questions, please reach out to WiscNet NOC.
Posted Aug 25, 2026 - 10:47 CDT
This incident affected: TEACH - Milwaukee (Mishicot School District).