Wiscnet - Oconomowoc SD - Slow upload speeds.

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 08:17 CDT

Investigating

Greetings,

The reported issue of slow upload speed is being investigated. Additional updates will be provided as they are available. Thank you.
Posted May 20, 2025 - 12:05 CDT
This incident affected: Oconomowoc Area School District.