Outage - Shebyogan Falls School District Down | 2222496

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 08:02 CDT

Monitoring

We have observed this connection restore at 7:35 AM CT.
Posted Apr 08, 2026 - 08:02 CDT

Investigating

We are currently investigating this issue.
Posted Apr 08, 2026 - 06:19 CDT
This incident affected: TEACH - Milwaukee (Sheboygan Falls School District).