Rib Lake School District - Down | #2236854

Incident Report for WiscNet

Resolved

We are seeing this site as back up. We will continue to monitor this as usual.
Posted May 13, 2026 - 17:36 CDT

Investigating

We are currently seeing circuit 400604 for Rib Lake School District as down. We have opened ticket 12129743 with GLS and will be following up with them.
Posted May 13, 2026 - 17:06 CDT
This incident affected: TEACH - Milwaukee (Rib Lake School District).