CESA 1 - Down | 2213656

Incident Report for WiscNet

Postmortem

Date & Time of Incident: 3/13/2026 at 1:11 PM Central Time

Duration: 10 minutes

Technician(s): Carter

Review Date: 03/13/2026

Brief Summary: Our team witnessed the site come into alarm, indicating an issue.

Root Cause: Provider network

Posted Mar 13, 2026 - 13:29 CDT

Resolved

Hello,

We observed this circuit down between 1:11 and 1:21 PM Central Time. At this time we are seeing all services restored.

Please reach out with any questions.

Thank you,
Posted Mar 13, 2026 - 13:28 CDT
This incident affected: TEACH - Milwaukee (CESA 1).