WiscNet - Waterford Union HS - Down | 2225325

Incident Report for WiscNet

Postmortem

Date & Time: 3:43AM CDT 4/14

Duration: 1462 Minutes

Technicians: Julio, Octavia, Dylan

Review Date: 4/15

Brief Summary: Commercial power outage

Posted Apr 15, 2026 - 09:04 CDT

Resolved

This outage is now restored. If you have any further questions or are still experiencing issues, please don't hesitate to reach out!
Posted Apr 15, 2026 - 09:02 CDT

Investigating

We are currently seeing Waterford Union HS as down starting at 9:43 PM. We have opened ticket 12071814 with GLS for this. Since there are multiple power outages in the area, please confirm power on site for this circuit.
Posted Apr 14, 2026 - 22:40 CDT
This incident affected: TEACH - Milwaukee (Waterford UHS School District).