[2280949] Luxemburg School District - Down

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 06:56 CDT

Update

Hello,

We have opened an investigation with our provider. We will provide further information when we receive further detail on their findings.
Posted Aug 24, 2026 - 06:43 CDT

Update

Hello,

At 6:04 AM CST we noticed r-luxemburgsd go down. We will work on opening an investigation with our provider. We will provide further updates as we receive them.
Posted Aug 24, 2026 - 06:21 CDT

Investigating

We are investigating this issue.
Posted Aug 24, 2026 - 06:20 CDT
This incident affected: Luxemburg-Casco School District.