Outage Concordia hub device down | 2231990

Incident Report for WiscNet

Resolved

The maintenance event is over and we are seeing services restored
Posted Apr 30, 2026 - 06:14 CDT

Identified

A maintenance event has taken down services. Work is expected to last until 6am.
Posted Apr 30, 2026 - 00:41 CDT

Investigating

We are currently investigating this issue.
Posted Apr 30, 2026 - 00:28 CDT
This incident affected: TEACH - Milwaukee (Concordia University, Nicolet UHS School District).