2206318 - Lakeshore TC - Manitowoc Campus - Down

Incident Report for WiscNet

Resolved

We are seeing this site as back up and operational. We will continue to monitor the site as normal.
Posted Feb 23, 2026 - 19:32 CST

Update

The WiscNet NOC has contacted GLS on your behalf and opened ticket 11981248, for additional information, please reach out to the GLS NOC at 1.866.558.1920. The GLS Engineering team will be reaching out for power verification on site.
Posted Feb 23, 2026 - 18:30 CST

Investigating

At 2/23/2026 5:37 PM Central, we became aware of alarm indicating an outage impacting Lakeshore TC - Manitowoc Campus. Circuit 401332.
Posted Feb 23, 2026 - 18:03 CST
This incident affected: TEACH - Milwaukee (Lakeshore Technical College).