Multiple Sites Unreachable 4/18 | 2226871

Incident Report for WiscNet

Postmortem

Date & Time of Incident: 4/18/26 - 11:43 AM CST

Duration: 86 minutes

Technician(s): Dante/Zach

Review Date: 4/20

Brief Summary: Multiple sites went down due storms

Root Cause: Provider outages due to storms

Posted Apr 20, 2026 - 11:43 CDT

Resolved

No further issues have been observed.
Posted Apr 19, 2026 - 17:36 CDT

Monitoring

Hello,

We are currently observing all services restored and are monitoring for further issues.
Posted Apr 18, 2026 - 14:02 CDT

Update

Hello,

We have reached out to TEACH and they are currently investigating. We will update as soon as further information is available.
Posted Apr 18, 2026 - 13:10 CDT

Investigating

Hello,

We are observing multiple sites down as of 11:43 AM. We are investigating further.
Posted Apr 18, 2026 - 12:19 CDT
This incident affected: TEACH - Madison (Belmont Community School District, Benton School District, Cuba City School District, Darlington Community School District, Shullsburg School District, Southwestern Wisconsin School District).