Crivitz School District Unreachable | 2213251

Incident Report for WiscNet

Resolved

We observed the site restore by 3:40PM CDT 3/12/2026.

We will continue monitoring as normal.
Posted Mar 12, 2026 - 17:42 CDT

Monitoring

Hello,

The WiscNet NOC was notified that network outage alarms today are due to electrical work, and the connection will appear offline until approximately late this evening. We will monitor for restoral, please reach out if you have any questions.
Posted Mar 12, 2026 - 15:34 CDT

Investigating

Hello,

The WiscNet NOC has observed the router become unreachable, please verify power and equipment onsite.
Posted Mar 12, 2026 - 15:08 CDT
This incident affected: TEACH - Madison (Crivitz School District).