Mass outage - multiple sites down | 2233852

Incident Report for WiscNet

Resolved

Hello,

All sites restored around 1:30 am.

Please reach out with any questions.

Thank you,
Posted May 06, 2026 - 06:57 CDT

Investigating

We are currently investigating this issue.
Posted May 06, 2026 - 01:06 CDT
This incident affected: TEACH - Madison (Hurley School District, Mercer School District, North Lakeland School District, Northwood School District, Solon Springs School District).