Rib Lake School District | 2266361

Incident Report for WiscNet

Postmortem

Hello, This issue was due to a power outage at the school.

Posted Jul 27, 2026 - 08:46 CDT

Resolved

Hello,

This issue was due to a power outage at the school.
Posted Jul 27, 2026 - 08:46 CDT

Investigating

We are seeing this site down as of 7:13 AM. Please reach out to GLS for further investigation for this outage. If you have any questions please reach out to us.
Posted Jul 24, 2026 - 07:25 CDT
This incident affected: TEACH - Milwaukee (Rib Lake School District).