Incident | Wausaukee School district | 2244605

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 05:49 CDT

Investigating

We are observing alarms indicating this site is down at this time. Please verify power to the device and all equipment is properly and securely cabled. If further assistance is needed please open a ticket with GLS at 1.866.558.1920
Posted Jun 05, 2026 - 00:39 CDT
This incident affected: TEACH - Madison (Wausaukee School District).