Herman-Neosho-Rubicon School District Down | #2187058

Incident Report for WiscNet

Resolved

Hello,

This site has restored as of 10:20 AM on 12/25
Posted Dec 25, 2025 - 13:17 CST

Investigating

Beginning at 8:10 AM on 12/25, alarms were observed indicating an outage at Herman-Neosho-Rubicon School District.
Posted Dec 25, 2025 - 09:15 CST
This incident affected: HNR School District- Rubicon.