Wiscnet Mass Outage 04/27/2026 | #2231045

Incident Report for WiscNet

Resolved

All sites should now be up and running. WiscNet convinced the Spectrum technicians on site to move the circuits to another port, and after they completed that work the connections started to come back up.

WiscNet Leadership will press on Spectrum to meet about these incidents to avoid this from happening again
Posted Apr 28, 2026 - 13:02 CDT

Update

Hello,

Spectrum continues their efforts to restore services.

They are currently working on some configuration issues and do not have an ETR as of yet.

We will update you further as work progresses.
Posted Apr 28, 2026 - 11:37 CDT

Update

Hello,

Spectrum continues their investigation on site in Eau Claire, WI.

At this time, an ETR has not been made available.

Further updates will be provided as they continue to work to troubleshoot and resolve this outage.
Posted Apr 28, 2026 - 09:12 CDT

Update

Spectrum technicians are on site in Eau Claire and working on the issue.
Posted Apr 28, 2026 - 08:49 CDT

Update

Hello,

We are still working with the provider to find the issue. No ETR currently. We will update when we have more information.

Thanks,
Posted Apr 27, 2026 - 22:30 CDT

Update

Hello,

We are still investigating the issue. No ETR currently. We will update when we have more information.

Thanks,
Posted Apr 27, 2026 - 18:00 CDT

Investigating

Hello,

We currently are observing a mass outage with one of our providers. We will update you when we learn more.


Thank you,
Posted Apr 27, 2026 - 15:41 CDT
This incident affected: TEACH - Milwaukee (Geneva J4 School District, Genoa City J2 School District, Holmen School District), Colby School District, School District of Ladysmith, Mid-State Technical College, Neillsville School District, Northland College, Owen-Withee School District, Rhinelander School District, Stanley-Boyd Area School District, Thorp School District, Waupaca County, and TEACH - Madison (Osceola School District, Saint Croix Falls School District).