West Allis-West Milwaukee School District | Down | 2220442

Incident Report for WiscNet

Resolved

By 12:34PM CDT 4/2/2026 we observe services restore.

Please reach out to the WiscNet NOC for any questions.
Posted Apr 03, 2026 - 21:03 CDT

Investigating

At 4:25PM CDT, we are observing the West Allis-West Milwaukee School District site as down.

Please confirm power on-site and to the equipment.
Posted Apr 01, 2026 - 16:57 CDT
This incident affected: West Allis-West Milwaukee School District.