[INC0058640] [WiscNet] [Slow performance on WiscNet mail relay]
Incident Report for WiscNet
Resolved
We have received multiple reports that the WiscNet mail relay is back to expected performance. Please contact support@wiscnet.net if you experience any further problems with the relay.
Posted Dec 29, 2021 - 10:24 CST
Monitoring
We have gotten the WiscNet mail relay removed from the last major blocklists, including Microsoft email domains such as Hotmail, Outlook, MSN, etc. The last message refused from these domains was logged at approximately 10:00am December 21st. We are continuing to monitor logs, please contact support@wiscnet.net if your mail is still being refused from these domains.
Posted Dec 21, 2021 - 16:01 CST
Update
There continue to be delivery delays or bounces with some larger email hosts such as Hotmail, Outlook, Msn, and others.

We are communicating with Microsoft as well as de-listing from blocklists to resolve this issue,
Posted Dec 02, 2021 - 12:12 CST
Identified
Wiscnet's mail server, mail.wiscnet.net / smtp.wiscnet.net, had spam relayed through it over Friday and Saturday, which caused it to have its mail queue backlogged, as well as listed on some blocklists.

Spam email has been purged and requests to blocklists have been sent to restore the IP's reputation.

The mail queue still contains many emails that are not yet accepted by recipient mail servers due to rate limiting and reputation.
Posted Nov 30, 2021 - 15:25 CST
Investigating
Notification of an unplanned event affecting your institution:

We have received multiple reports of slow delivery through the WiscNet mail relay, often taking an hour or more. WiscNet technicians are investigating and hope to find a cause shortly.

Please contact the WiscNet NOC if you have any further questions.

608-442-6761 option 1
noc@wiscnet.net
Posted Nov 29, 2021 - 22:20 CST
This incident affected: Abbotsford School District, Adams-Friendship Area School District, Albany School District, Algoma School District, Village of Allouez, Almond-Bancroft School District, Altra Federal Credit Union, Altoona City, Altoona School District, Alverno College, Antigo Unified School District, Appleton Area School District, Appleton Boys and Girls Club, City of Appleton, Appleton Performing Arts Center, Argyle School District, Arrowhead UHS School District, Ashwaubenon School District, Village of Ashwaubenon, Auburndale School District, Aurora University, Augusta School District, Bangor School District, Baraboo School District, Barneveld School District, Barron Area School District, Beecher-Dunbar-Pembine School District, Belleville School District, Bellin College Inc, Belmont Community School District, City of Beloit, Beloit College, Beloit School District, Benton School District, Berlin Area School District, Big Foot UHS School District, Birchwood School District, Black Hawk School District, Blackhawk Technical College, BloodCenter of Wisconsin, Bonduel School District, Boscobel Area School District, Bowler School District, Boyceville Community School District, Brighton #1 School District, Brillion School District, Bristol School District #1, City of Brookfield, Brown County, Brown County 2 Remote Site, Brown County 3 Remote Site, Brown County Jail, Brown County Law Enforcement, Brown County New Eye, Brown County PDCT, Brown County PDCT 2, Brown County Public Service Commission, Burlington Area School District, Cadott Community School District, Calumet County, Cambria-Friesland School District, Cambridge School District, Cameron School District, Campbellsport School District, Carroll University, Carthage College, Cassville School District, Catholic Memorial High School, CESA 1, CESA 2, CESA 3, CESA 4, CESA 5, CESA 6, CESA 7, CESA 8, CESA 9, CESA 10 - Chippewa Falls, CESA 10 - Madison, CESA 11, Chetek-Weyerhaeuser School District, Children Hospital and Health System, Chilton School District, Chippewa County, Chippewa Valley Technical College, Chippewa Falls Area Unified School District, Clear Lake School District, Clinton Community School District, Cochrane-Fountain City School District, Colby School District, Coleman School District, Colfax School District, Concordia University, Cornell School District, Crivitz School District, Cuba City School District, Cudahy School District, D C Everest Area School District, Dane County, Darlington Community School District, Deerfield Community School District, De Forest Area School District, City of De Pere, De Pere School District, Delavan-Darien School District, Denmark School District, Dodgeland School District, Dodgeville School District, Door County, Dove Health Care, Dunn County, East Troy School District, Eastern Shores Library System - Monarch Library System, Eau Claire Area School District, Eau Claire Catholic Schools, City of Eau Claire, Eau Claire County, Edgar School District, Edgerton School District, Edgewood High School, Educators Credit Union, Elcho School District, Elk Mound Area School District, Elkhart Lake-Glenbeulah School District, Elkhorn Area School District, Ellsworth Community School District, Elmbrook School District, Elmwood School District, Erin School District, Fall Creek School District, Fall River School District, Family Peace Center, Flambeau School District, Florence County School District, City of Fond du Lac, Fond du Lac County, Fond du Lac School District, Fontana J8 School District, Fort Atkinson School District, Fox Point J2 School District, Fox Valley Lutheran High School, Fox Valley Technical College, Frederic School District, Freedom Area School District, Geneva J4 School District, General Mitchell International Airport, Genoa City J2 School District, Germantown School District, Gillett School District, Gilmanton School District, Glenwood City School District, Good Shepherd Lutheran School, Goodman-Armstrong Creek School District, Grafton School District, Town of Grand Chute, Granton Area School District, Grantsburg School District, City of Green Bay, Green Bay Area School District, Green Bay Community Church, Green Lake County, Green Lake School District, City of Greenfield, Greenfield School District, Greenwood School District, Gresham School District, Hartford J1 School District, Hartford UHS School District, Hartland-Lakeside J3 School District, Hayward Community School District, Highland School District, Hilbert School District, HNR School District-Neosho, HNR School District- Rubicon, Holmen School District, Holy Apostles School, Holy Hill Area School District, Horicon School District, Howard Village, Hortonville Area School District, Howard-Suamico School District, Howards Grove School District, Hudson School District, Hurley School District, Hustisford School District, Inclusa, Independence First, Indianhead Federated Library System, Iola-Scandinavia School District, Iowa-Grant School District, Ithaca School District, Jackson County, City of Janesville, Jefferson County, Jefferson School District, Johnson Creek Elementary, Johnson Creek School District, Kaukauna Area School District, Kenosha County, Kenosha County Public Library System, Kenosha Unified School District, Kettle Moraine School District, Kewaskum School District, Kewaunee School District, Kiel Area School District, Kimberly Area School District, Kohler School District, City of La Crosse, La Crosse School District, Lac Courte Oreilles Ojibwa Community College, Lac du Flambeau #1 School District, School District of Ladysmith, Lake Country School District, Lake Holcombe School District, Lake Mills Area School District, Lakeland College, Lakeland UHS School District, Lakeshore Technical College, Lakeshores Library System, Laona School District, Lawrence University, Lena School District, Lincoln County, Linn J6 School District, Little Chute Area School District, Village of Little Chute, Lodi School District, Lomira School District, Loyal School District, Luther High School, Luxemburg-Casco School District, Madison Area Technical College, City of Madison, Madison Metropolitan School District, Manawa School District, Manitowoc Public Utilities, Manitowoc School District, Maple Dale-Indian Hill School District, Marathon City School District, Marathon County, Marian University of Fond du Lac, Marinette City, Marinette County, Marinette School District, Marion School District, Markesan School District, Marquette University, Marquette University High School, Marshall School District, City of Marshfield, Marshfield Unified School District, Mayville School District, McDonell Area Catholic School District, McFarland School District, Medford Area Public School District, Medical College of Wisconsin, City of Menasha, Menasha Joint School District, Town of Menasha, Menasha Utilities, Menominee Indian School District, Menomonie Area School District, Mequon-Thiensville School District, Mercer School District, Meriter Hospital, Inc., Merton Community School District, Messmer Catholic, Mid-State Technical College, Mid-State Technical College - Stevens Point, Mid-Wisconsin Federated Library System, Middleton-Cross Plains Area School District, Milton School District, Milwaukee Area Technical College, Milwaukee Art Museum, Milwaukee City Housing Authority, City of Milwaukee, Milwaukee County Federated Library System, Milwaukee Institute of Art and Design, Milwaukee Public Museum, Milwaukee School of Engineering, Mineral Point Unified School District, Minocqua J1 School District, Mishicot School District, Mondovi School District, Monona Grove School District, Monroe School District, Montello School District, Monticello School District, Moraine Park Technical College, Mosinee School District, Mukwonago School District, Muskego-Norway School District, Necedah Area School District, City of Neenah, Neenah Joint School District, Neillsville School District, City of New Berlin, New Berlin School District, New Glarus School District, New London School District, Niagara School District, Nicolet Area Technical College, Nicolet Federated Library System, Nicolet UHS School District, Norris Academy, North Central Health Care, North Fond du Lac School District, North Lakeland School District, Northcentral Technical College, Northeast Wisconsin Technical College, Northern Ozaukee School District, Northern Waters Library Service, Northland College, Northland International University, Northland Pines School District, Northwood School District, Norwalk-Ontario-Wilton School District, Oconomowoc Area School District, Oconto Falls Public School District, Oconto Unified School District, Omro School District, Oregon School District, Osceola School District, Oshkosh Area School District, City of Oshkosh, Osseo-Fairchild School District, Outagamie Waupaca Library System, Owen-Withee School District, Pabst Theater Organization, Palmyra-Eagle Area School District, Parkview School District, Paris J1 School District, Pecatonica Area School District, Peshtigo School District, PESI, Pewaukee School District, Phelps School District, Phillips School District, Pier Wisconsin, Pittsville School District, City of Platteville, Platteville School District, Plum City School District, Plymouth Joint School District, Port Edwards School District, Port Washington-Saukville School District, Portage Community School District, Portage County, Poynette School District, Prairie du Chien Area School District, Prairie Farm Public School District, Prentice School District, Prescott School District, Price County, Princeton School District, Pulaski Community School District, Racine Lutheran High School, Racine Unified School District, Randall J1 School District, Randolph School District, Raymond #14 School District, Reedsville School District, Rhinelander School District, Rib Lake School District, Rice Lake Area School District, Richmond School District, Rio Community School District, Ripon Area School District, Ripon College, River Falls School District, River Ridge School District, River Valley School District, Riverdale School District, Rock County, Rock Prairie Montessori, Rosendale-Brandon School District, Rosholt School District, Royal Credit Union, Rubicon J6 School District, Rural Health Care, Sacred Heart Hospital, Sacred Heart of Jesus and Mary School, Sacred Heart School of Theology, St. Augustine University Parish, St. Catherines High School, Saint Croix Central School District, Saint Croix Falls School District, St. Francis Xavier Catholic School Systems, St. Joseph's Hospital, St. Mary Catholic Schools, St. Mary's Springs Academy, St. Norbert College, St. Thomas Aquinas Parish School, St. Vincent Hospital, Salem School District, Sauk Prairie School District, Sevastopol School District, Sharon J11 School District, Shawano School District, Sheboygan Area School District, City of Sheboygan, Sheboygan County, Sheboygan Falls School District, Shell Lake School District, Shiocton School District, Shoreland Lutheran High School, Shullsburg School District, Silver Lake College, Siren School District, Slinger School District, Solon Springs School District, South Central Library System, Southern Door County School District, Southwest Health Center, Southwest Library System, Southwest Wisconsin Technical College, Southwestern Wisconsin School District, Sparta Area School District, Spencer School District, Spooner Area School District, Spooner Health System, Spring Valley School District, Stanley-Boyd Area School District, Stevens Point Area Public School District, City of Stevens Point, Stone Bank School District, Stoughton Area School District, Stratford School District, Sturgeon Bay School District, Village of Suamico, Sun Prairie Area School District, City of Superior, Suring Public School District, Swallow School District, SWITCH - Southeastern Wisc Info Tech Exchange, Thorp School District, Three Lakes School District, Tigerton School District, Tomahawk School District, Tomorrow River School District, Tri-County Area School District, Trout Lake, Turtle Lake School District, Two Rivers Public School District, Union Grove J1 School District, Union Grove UHS School District, UW Platteville Real Estate Foundation, UW-Whitewater, Verona Area School District, Victory Christian Academy, Victory Christian Academy - 2, Viterbo University, Wabeno Area School District, Walworth J1 School District, Washburn County, Washington-Caldwell School District, Waterford Graded J1 School District, Waterford UHS School District, Waterloo School District, Watertown Unified School District, City of Waukesha, Waukesha County, Waukesha County Federated Library System (Bridges Library System), Bridges Library System, Waukesha County Technical College, Waukesha School District, Waunakee Community School District, Waupaca County, Waupaca School District, Waupun School District, City of Wausau, Wausau School District, Wausaukee School District, Wautoma Area School District, Wauwatosa City, Wauzeka-Steuben School District, Webster School District, City of West Allis, West Allis-West Milwaukee School District, West De Pere School District, West Salem School District, Western Technical College, Westfield School District, Westosha Special Ed, Weyauwega-Fremont School District, White Lake School District, Whitefish Bay Dominican High School, Whitefish Bay School District, City of Whitewater, Whitewater Unified School District, Whitnall School District, School District of Wild Rose, Winding Rivers Library System, Winnebago County, Winnebago Lutheran Academy, Winneconne Community School District, Winnefox Library System, Winter School District, Wisconsin Center for the Blind and Visually Impaired, Wisconsin Dells School District, Wisconsin Department of Military Affairs, State of Wisconsin Dept of Public Instruction, Wisconsin Department of Transportation, Wisconsin Economic Development Corporation - Madison, Wisconsin Economic Development Corporation - Milwaukee, Wisconsin Heights School District, Northwood Technical College, State of Wisconsin Investment Board, Wisconsin Lutheran College, Wisconsin Lutheran High School, Wisconsin School for the Deaf, State of Wisconsin, Wisconsin Technical College System, Wisconsin Valley Library Service, Wonewoc-Union Center School District, Woodruff J1 School District, Wrightstown Community School District, Wisconsin Regional Peering (MERIT Network, Pennsylvania State University, SysNet, Indiana Giga POP, Northwestern University, University of Chicago, University of Iowa, University of Illinois, NorthernLights GigaPOP, UW SysNet, Illinois State University, Penn State University, KINBER, MOREnet, Iowa State University, University of Nebraska CSN, University of Nebraska Lincoln, University of Missouri, OneNet, GPN), and Transit Share (University of Wisconsin SysNet, University of Iowa, Penn State, University of Minnesota, Indiana University, MERIT, KINBER, Iowa State University).