West Salem School District - 400661 - Down | 2210340

Incident Report for WiscNet

Resolved

We have observed our device connection restore at 11:01AM CT today.
Posted Mar 05, 2026 - 11:22 CST

Investigating

The WiscNet NOC has lost access to our device for West Salem School District at 10:30AM 03/05/2026. Please verify power to your site and the network equipment. If you are not aware of any internal work occurring and believe this is a network event, please contact GLS Tech Support for 24x7/outages/incidents at 866-558-1920.
Posted Mar 05, 2026 - 10:48 CST
This incident affected: TEACH - Madison (West Salem School District).