2225486 | Sheboygan Falls School District Down

Incident Report for WiscNet

Resolved

Hello,

At this time we are seeing all services restored.

Please reach out with any questions.

Thank you,
Posted Apr 15, 2026 - 07:17 CDT

Update

Hello,

The WiscNet NOC has contacted GLS on your behalf and opened ticket 12071583, for additional information, please reach out to the GLS NOC at 1.866.558.1920.
Posted Apr 15, 2026 - 06:11 CDT

Investigating

Hello,

The WiscNet NOC has lost access to our device for Sheboygan Falls School District at 5:52am. Please verify power to your site and the network equipment. If you are not aware of any internal work occurring and believe this is a network event, please contact GLS Tech Support for 24x7/outages/incidents at 866-558-1920. The TEACH ID for this circuit is 1511.
Posted Apr 15, 2026 - 06:03 CDT
This incident affected: TEACH - Milwaukee (Sheboygan Falls School District).