Village of Howard - DOWN | #2203310

Incident Report for WiscNet

Update

Hello,

We are still seeing equipment for the Village of Howard as down. Our ticket ID is 2203310, if this outage is expected or if there's power issues onsite please reach out to 608-442-6761 option 1.
Posted Feb 13, 2026 - 15:55 CST

Investigating

Hello,


We are investigating a possible outage with the equipment for the Village of Howard. Our ticket ID is 2203310, if this outage is expected or if there's power issues onsite please reach out to 608-442-6761 option 1.

Thank you,
Posted Feb 12, 2026 - 15:47 CST
This incident affects: Howard Village.