Outage | Plum City School District Down | 2239519

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted May 21, 2026 - 06:06 CDT

Investigating

GLS has requested that plum city opens a ticket with them directly. While we investigate further, please verify connectivity to on site equipment and that power is also to the equipment.
Posted May 21, 2026 - 03:37 CDT
This incident affected: TEACH - Madison (Plum City School District).