Glenwood City School District - Down | 2194039

Incident Report for WiscNet

Resolved

Date & Time of Incident: 1/19/225 / 7:52 - 9:55 AM CST
Duration: 123 minutes
Technician(s): JH
Review Date: 1/19/225

Root Cause: Device reboot

Brief Summary: Device was down for 123 minutes. There were known power outages in the area.
Posted Jan 19, 2026 - 12:09 CST

Investigating

Hello,

We are seeing the Glenwood City School district as down starting at 7:52 AM CST. We've lost access to the router on site, please verify power & equipment and reach out to GLS/TEACH.

TEACH prefers that the site open a trouble ticket with the GLS. Please contact the GLS NOC at 1-866-558-1920 for additional troubleshooting and to open a ticket.

If you have any questions, feel free to reach out.
Posted Jan 19, 2026 - 08:18 CST
This incident affected: Northeast Wisconsin Technical College.